Jump to content

Incompatible version of Net-7 Proxy


Recommended Posts

I found a sort of awkward solution, this is after trying to reset the updates and reinstalling. I launched net7 and didn't press play, uninstalled net7 while the launch window is still open, then pressed check for updates and it came with the cannot detect version window and update, then i reinstalled net7, i got an error during reinstallation that it couldn't read or write to a specific file, clicked ignore and it went ahead. then went back to the launch window and continued with the update. after that everything went fine, did this on 2 computers a xp and win7 one. like i said its an awkward fix but worked for me.

Link to comment
Share on other sites

  • 5 years later...

Launch Admin mode and tell it to reset the updates, this should bring you from 'default' to current regardless of settings and should overwrite anything in the current release as we do. I'm not sure which Net7Proxy we're on without looking into it, but it may not be that version and we don't really retain older copies due to generally no need. When we update that, we want you to update as well and release it to you. Without a valid version, you cannot connect to the emulator.

Link to comment
Share on other sites

  • 1 month later...
  • 2 months later...

Anyone still have the net-7 single player version. The one that do not use mysql. 1.7 I think. Was a limited version but can use beta/admin commands. I did with tada-o version (sourceforge) but is a pain old mysql server and debug mode. The one that was xml file was funny. Thank you.

Edited by Antflyer
Link to comment
Share on other sites

On 1/5/2019 at 9:15 AM, Antflyer said:

Anyone still have the net-7 single player version. The one that do not use mysql. 1.7 I think. Was a limited version but can use beta/admin commands. I did with tada-o version (sourceforge) but is a pain old mysql server and debug mode. The one that was xml file was funny. Thank you.

 

No, we didn't retain this after we got to a stable multiplayer mode.

Link to comment
Share on other sites

I get "server failed to respond to login attempt" when I try and start via net-7 proxy. I reset updates in admin mode and did all the steps others have done and still have the same issue.

Link to comment
Share on other sites

10 hours ago, Beerrun said:

I get "server failed to respond to login attempt" when I try and start via net-7 proxy. I reset updates in admin mode and did all the steps others have done and still have the same issue.

 

Wrong internal IP selected on launcher or incoming UDP connection is blocked by firewall / router.

Link to comment
Share on other sites

to everyone who is having install issues:  -- hang in there.  Earth and Beyond does work.

 

and, PLEASE -- when you post your problem, tell the DEVs what operating system you are running and which service pack.  If you're trying to use a Windows emulator [on either an iMac or Linux box], they need those details as well.

 

Yes, Earth and Beyond apparently still runs on Win XP [SP 3].  It runs on Win 7 64 bit [I'm less sure about 32 bit -- haven't had a 32 bit computer in over a decade now].  It runs on Win 8 and Win 10.  Yes, you have to run the install under admin privileges [MicroSoft won't allow programs from outside sources to automatically select "run as admin" -- it's a fundamental safety measure].  And YES, after the program is installed, you then have to manually set the LaunchNet7.exe file to "run as admin" as well as run under the proper Windows compatibility mode {Win XP, SP 3 -- I admit that I'm unsure of this for Win 10 users since I'm refusing to use that operating system myself}.

 

And yes, it is quite possible that your anti-virus or anti-malware program, including the firewall in your router or computer, is stopping EnB from communicating with the server.  This can be fixed by creating an exception for the LaunchNet7.exe file in the preventing program.

 

 

We're looking forward to seeing you ingame ....

Link to comment
Share on other sites

  • 2 months later...

got the same message today, it was looking for version 2.45, was working on the same machine yesterday without the error.

 

inplace re-installed Net7

launcher > Help > Advanced Settings > "Force Update" 

*patches up to 542*

 

okay now, not sure what i messed up.

 

 

Edited by TempestNWK
Link to comment
Share on other sites

2 hours ago, TempestNWK said:

okay now, not sure what i messed up.

 

sounds like the launcher wasn't checking version when it started up.  Hopefully, the reinstall you did has that permanently fixed.

 

Alas, we may not know until the next patch ... not sure [I'm not a DEV] if there will be one for Easter [rabbit/egg hunting?] or not.

 

Have fun ingame until you find out ...

Link to comment
Share on other sites

  • 3 years later...

What started all this havoc was I thought my Net-7 Launcher was crashed.  It went to the task bar but didn't show.  I ran the net7launcher.bat and it went to my EA-Login no problem.  I still wanted the Launcher to work correctly.  I downloaded the launcher again.  Now that's when the net7proxy version problem started.   My Launcher was on the task bar it just wouldn't come up when I clicked it.  Before you muck up your install see if you can click the lauch.bat file in the net7/bin folder. this checks your net7proxy version,  If you come to EA Login screen, EXIT and follow steps below.

 

There was nothing really wrong with the Launcher other then it was minimized in the task bar.  *IF Clicking on it Does Nothing)  Go to the properties (right click on Launcher and set  or switch it to maximized and re launch it then set it to the size you want.

 

You HAVE to SET FILE PERMISSIONS in all your folders to get it to update!  Uncheck Read Only Properties.

When you click Launcher and try and update and the update box doesn't come up your properties or write permissions are still mucked up.

Just Launching the Net-7 Launcher in Admin Mode will not cut it.  You have to be able to overwrite the programs in Net7 folder.  You have to set write permissions correctly.  

 

If your Game is Not running in Full Screen Mode, Look in the E&B Config Section in the Launcher to Fix your screen resolution.

 

I Would really miss this game.. If they took it down again.    Thank You soo much to the people that got this going again, After EA Pulled the Plug on us.

 

I hope my comments are of some Value, Please Don't Give Up on it!  IT is a Windows Problem, You kind of have to be an advanced User,  Everything they Do here Works!  IT just takes a few advanced skills to fix it.

Edited by Timesoarer
Link to comment
Share on other sites

Hey,

 

you only need to run the Launcher in Admin Mode, as the guide says (must read tho...)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...