Jump to content

Something Happened?


Recommended Posts

I loaded the game a few weeks ago with no problem. Have played a character up to the mid 80's. Logged off saturday and when I came back on the same day I started getting errors in my Net7. I have run a repair on .net and used the feature to reset updates on net7 which changed the problem from no web site in the box to atleast seeing the blue screen with the admin comments, etc.

I still can't get into the game and the errors seem to indicate that its having a problem with the finding the client.

I also can't find uninstall for Net7 to reinstall and have tried to reinstall over it with no luck.

The error information I am getting is as follows.


See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.ArgumentException: The path is not of a legal form.
at System.IO.Path.NormalizePathFast(String path, Boolean fullCheck)
at System.IO.Path.NormalizePath(String path, Boolean fullCheck)
at System.IO.Path.GetDirectoryName(String path)
at LaunchNet7.FormMain.DoCheckForUpdates()
at LaunchNet7.FormMain.c_ToolStripMenuItem_Main_Launcher_CheckForUpdates_Click(Object sender, EventArgs e)
at System.Windows.Forms.ToolStripItem.RaiseEvent(Object key, EventArgs e)
at System.Windows.Forms.ToolStripMenuItem.OnClick(EventArgs e)
at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)
at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
at System.Windows.Forms.ToolStripItem.FireEventInteractive(EventArgs e, ToolStripItemEventType met)
at System.Windows.Forms.ToolStripItem.FireEvent(EventArgs e, ToolStripItemEventType met)
at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)
at System.Windows.Forms.ToolStripDropDown.OnMouseUp(MouseEventArgs mea)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.ToolStrip.WndProc(Message& m)
at System.Windows.Forms.ToolStripDropDown.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3623 (GDR.050727-3600)
CodeBase: file:///C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
LaunchNet7
Assembly Version: 1.9.9.10
Win32 Version: 1.9.9.10
CodeBase: file:///C:/NET7/bin/LaunchNet7.exe
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3623 (GDR.050727-3600)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3624 (GDR.050727-3600)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Configuration
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3082 (QFE.050727-3000)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

I haven't made any changes to my pc so not sure what the heck could be going on.

Any info or suggestions please let me know.
FYI the sticky posts do not indicate this is a usual problem or has a solution.

Thank you for your time.

bk
Link to comment
Share on other sites

chances are as you suspected it looks like a problem with .net. It could be a bad auto-patch from MS (been getting a lot of these lately - found I needed to re-install .Net 3.5 and 4.0 to fix).

If re-installing .net (or some other solution) doesn't help there is a temp stopgap you can use. I don't recommend using this for long as your proxy will become obsolete without the patching tool:

open a command prompt.

type cd \

cd net7\bin

net7proxy /ADDRESS:87.106.131.253 /POPT /CLIENT:"C:\\applications\\Earth & Beyond\\release\\client.exe"

**Note that where you install your client will be different to the file address used above, you need to locate where you installed your client**

this will get you into the game via the backdoor so to speak, although you will not get updates via this method, so it would be a good idea to try to fix whatever problem is occurring.
Link to comment
Share on other sites

[quote name='badkarmaxv' timestamp='1317081132' post='46702']
Server failed to respond to login attempt is the message I get from trying the back door.

I have either repaired, rolled back or re-installed down to 3.5 NET and nothing seems to be making a difference.
[/quote]


Are you suggestion I re-install the game? I have since tried to load this all onto my lap top which uses vista versus xp on my main system and I am getting the same problem. Fresh install and all so not sure that will do anything?
Link to comment
Share on other sites

The requirements to run are .NET 2.0 (which with XP you must make sure is installed, not so with Vista or 7 that I know of). VC++ Redistributable pack is also one of the requirements.

There isn't a new installer currently available that you can install with, but what simply needs to happen is that the config file needs to create with a path to wherever you have the game client installed at, the default location for the game client is:

C:\Program Files\EA Games\Earth & Beyond\release\client.exe
Link to comment
Share on other sites

[quote name='Kyp' timestamp='1317081824' post='46705']
The requirements to run are .NET 2.0 (which with XP you must make sure is installed, not so with Vista or 7 that I know of). VC++ Redistributable pack is also one of the requirements.

There isn't a new installer currently available that you can install with, but what simply needs to happen is that the config file needs to create with a path to wherever you have the game client installed at, the default location for the game client is:

C:\Program Files\EA Games\Earth & Beyond\release\client.exe
[/quote]

I have my game loaded in the above pathway. It is identical.

I have compared the files with a friend on vent and I find that I don't have a uninstall.exe in my Net 7 bin folder and he does. I deleted the folder and the shortcuts and reloaded it and found that again I do not have an uninstall like they do and the errors still the same.

I also have no access to browse or choose the pathway in the client box of Net7 to put that info in.

So should I uninstall all the net. versions above 2 on my XP system? and see what that does since its for XP versus the higher versions for vista, etc?

The error log reads as under help...



LaunchNet7 - Exception
Version: 1.8.1.0
Time: Mon, 26 Sep 2011 19:43:06 GMT
Message: The operation has timed out
System.Net.WebException: The operation has timed out
at System.Net.HttpWebRequest.GetResponse()
at LaunchNet7.LauncherUtility.DownloadString(String url, Int32 timeoutInMilliseconds)
at LaunchNet7.LauncherUtility.DownloadString(String url)
at LaunchNet7.Updateing.Updater.CheckForUpdates()


LaunchNet7 - Exception
Version: 1.8.1.0
Time: Mon, 26 Sep 2011 19:43:10 GMT
Message: The operation has timed out
System.Net.WebException: The operation has timed out
at System.Net.HttpWebRequest.GetResponse()
at LaunchNet7.LauncherUtility.DownloadString(String url, Int32 timeoutInMilliseconds)
at LaunchNet7.LauncherUtility.DownloadString(String url)
at LaunchNet7.Updateing.Updater.CheckForUpdates()


LaunchNet7 - Exception
Version: 1.8.1.0
Time: Mon, 26 Sep 2011 19:43:35 GMT
Message: Could not launch client.
System.ApplicationException: Could not launch Net7 Server. Details: The system cannot find the file specified ---> System.ComponentModel.Win32Exception: The system cannot find the file specified
at System.Diagnostics.Process.StartWithShellExecuteEx(ProcessStartInfo startInfo)
at System.Diagnostics.Process.Start()
at System.Diagnostics.Process.Start(ProcessStartInfo startInfo)
at LaunchNet7.Launcher.LaunchNet7Server()
--- End of inner exception stack trace ---
at LaunchNet7.Launcher.LaunchNet7Server()
at LaunchNet7.Launcher.Launch()
at LaunchNet7.FormMain.DoLaunch(LaunchSetting setting)


LaunchNet7 - Exception
Version: 1.8.1.0
Time: Mon, 26 Sep 2011 20:09:58 GMT
Message: The operation has timed out
System.Net.WebException: The operation has timed out
at System.Net.HttpWebRequest.GetResponse()
at LaunchNet7.LauncherUtility.DownloadString(String url, Int32 timeoutInMilliseconds)
at LaunchNet7.LauncherUtility.DownloadString(String url)
at LaunchNet7.Updateing.Updater.CheckForUpdates()


LaunchNet7 - Exception
Version: 1.8.1.0
Time: Mon, 26 Sep 2011 20:10:02 GMT
Message: The operation has timed out
System.Net.WebException: The operation has timed out
at System.Net.HttpWebRequest.GetResponse()
at LaunchNet7.LauncherUtility.DownloadString(String url, Int32 timeoutInMilliseconds)
at LaunchNet7.LauncherUtility.DownloadString(String url)
at LaunchNet7.Updateing.Updater.CheckForUpdates()


LaunchNet7 - Exception
Version: 1.8.1.0
Time: Mon, 26 Sep 2011 21:38:23 GMT
Message: Could not launch client.
System.ApplicationException: Could not launch Net7 Server. Details: The system cannot find the file specified ---> System.ComponentModel.Win32Exception: The system cannot find the file specified
at System.Diagnostics.Process.StartWithShellExecuteEx(ProcessStartInfo startInfo)
at System.Diagnostics.Process.Start()
at System.Diagnostics.Process.Start(ProcessStartInfo startInfo)
at LaunchNet7.Launcher.LaunchNet7Server()
--- End of inner exception stack trace ---
at LaunchNet7.Launcher.LaunchNet7Server()
at LaunchNet7.Launcher.Launch()
at LaunchNet7.FormMain.DoLaunch(LaunchSetting setting)


LaunchNet7 - Exception
Version: 1.9.9.10
Time: Tue, 27 Sep 2011 00:26:24 GMT
Message: Could not load AuthLogin.log.
System.Configuration.ConfigurationErrorsException: Configuration system failed to initialize ---> System.Configuration.ConfigurationErrorsException: Root element is missing. (C:\Documents and Settings\Sean Henke\Local Settings\Application Data\LaunchNet7\LaunchNet7.exe_Url_33uz3155fe0lw51jyicbrfpxh3h01gh0\1.9.9.10\user.config) ---> System.Xml.XmlException: Root element is missing.
at System.Xml.XmlTextReaderImpl.Throw(Exception e)
at System.Xml.XmlTextReaderImpl.ThrowWithoutLineInfo(String res)
at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
at System.Xml.XmlTextReaderImpl.Read()
at System.Xml.XmlTextReader.Read()
at System.Configuration.XmlUtil..ctor(Stream stream, String name, Boolean readToFirstElement, ConfigurationSchemaErrors schemaErrors)
at System.Configuration.BaseConfigurationRecord.InitConfigFromFile()
--- End of inner exception stack trace ---
at System.Configuration.ConfigurationSchemaErrors.ThrowIfErrors(Boolean ignoreLocal)
at System.Configuration.BaseConfigurationRecord.ThrowIfParseErrors(ConfigurationSchemaErrors schemaErrors)
at System.Configuration.BaseConfigurationRecord.ThrowIfInitErrors()
at System.Configuration.ClientConfigurationSystem.OnConfigRemoved(Object sender, InternalConfigEventArgs e)
--- End of inner exception stack trace ---
at System.Configuration.ConfigurationManager.PrepareConfigSystem()
at System.Configuration.ConfigurationManager.RefreshSection(String sectionName)
at System.Configuration.ClientSettingsStore.ReadSettings(String sectionName, Boolean isUserScoped)
at System.Configuration.LocalFileSettingsProvider.GetPropertyValues(SettingsContext context, SettingsPropertyCollection properties)
at System.Configuration.SettingsBase.GetPropertiesFromProvider(SettingsProvider provider)
at System.Configuration.SettingsBase.GetPropertyValueByName(String propertyName)
at System.Configuration.SettingsBase.get_Item(String propertyName)
at System.Configuration.ApplicationSettingsBase.GetPropertyValue(String propertyName)
at System.Configuration.ApplicationSettingsBase.get_Item(String propertyName)
at LaunchNet7.Properties.Settings.get_ClientPath()
at LaunchNet7.FormAdvancedSettings.DoDisplayAuthloginLog()

The first thing that jumps out at me is that the net 7 updated and is showing at 1.9.9 to me but the errors are still showing the last version still. Edited by badkarmaxv
Link to comment
Share on other sites

[quote name='Kyp' timestamp='1317083318' post='46710']
Unzip this and copy it over the LaunchNet7.exe in your launcher's install folder. C:\Net7\bin probably.

[attachment=1026:LaunchNet7.zip]
[/quote]


Appreciate you taking the time with me on this.

I copied the file over the one in the folder and Net 7 showed no change. I tried just clicking on the exe and it did get me into the game and to log in but at the log in it gave me the message "Connection to the Global Server Failed" and the game exits out to windows.

I also tried to reset updates to get back to 1.8.0 and it said it did but not showing the change or allowing for updates.
Link to comment
Share on other sites

[quote name='badkarmaxv' timestamp='1317086689' post='46717']
starting that now.
[/quote]

Okay so to synopsis this.

I was playing enb since I reloaded this in late august.
Saturday for some reason the game crashed and now I am unable to log in.

I have re-installed and ran repairs on all Net versions on my pc.

I have now deleted both the game and net7. made sure all files where gone and re-installed.
I re-installed the game. Re-installed the update.
I then loaded Net7.

When I opened Net7 the green bar filled half way and then it gave me an update to an unspecific version number.
I accepted and once it was done the white screen in the box was replaced by the web site info/dev communications to community and its up to ver.1.9.9.

I am unable to access any of the drop downs, manipulate any boxes or browse input information above the location on Net 7 that says open in another window.

Using the net7.exe file again nothing changed and when i try the exe on its own it still gets me into the game but tells me "connection to the Global Server Failed"

I am running XP and the admin so not able to actually set it as "admin". Not an option by right clicking and being sure.

So in short I am stumped. I was wondering if perhaps IP ranges could have been blocked to the server in some way that is causing these failed to connect errors now?

Anymore suggestions?
Link to comment
Share on other sites

We've not changed any code on the public server since the 15th or whenever it was we pushed that last content patch. (I think that's about right).

I couldn't really say at this point, the only thing I could recommend doing is catch one of our GMs or tech support (or even one of us) in the Teamspeak and we can try to help via a remote connection client or something.
Link to comment
Share on other sites

[quote name='Kyp' timestamp='1317156273' post='46761']
We've not changed any code on the public server since the 15th or whenever it was we pushed that last content patch. (I think that's about right).

I couldn't really say at this point, the only thing I could recommend doing is catch one of our GMs or tech support (or even one of us) in the Teamspeak and we can try to help via a remote connection client or something.
[/quote]


Thanks, I will try and make time for that. I have since tried loading this fresh on 2 pc's with XP and a laptop with Vista.

XP - Net 7 - problem we have been talking about.
XP 2 - Net7 - The application failed to intialize properly (0x0000135). Click on OK to terminate the application.
Vista - Net 7 - Font Courier New "regular" not supported error at load up.

Hasn't been a good week for getting my enb fun in that's for sure lol.
Link to comment
Share on other sites

XP - I'd have to see it.
XP2 - [color=#444444][font=Tahoma, Verdana, Arial,]The application failed to intialize properly (0x0000135). Click on OK to terminate the application.[/font][/color]
[color=#444444][font=Tahoma, Verdana, Arial,]
[/font][/color]
[color=#444444][font=Tahoma, Verdana, Arial,]Indicates the machine likely doesn't have the .NET, this is used for the game Launcher to run.[/font][/color]
[color=#444444][font=Tahoma, Verdana, Arial,]
[/font][/color]
[color=#444444][font=Tahoma, Verdana, Arial,]Vista - I don't know how to break this one gently, but YOU'RE USING VISTA. :D[/font][/color]
Link to comment
Share on other sites

Yeah, Kyp is correct about Vista. Try to get to Windows 7 Pro or Ultimate when you can. Its a much better OS in many ways.

Something not touched on here is Internet Security software. Make sure you have an exception setup for Net-7 and the Client as well, then give it a whirl.

-Overt.
Link to comment
Share on other sites

  • 2 weeks later...
[quote name='Overtkill' timestamp='1317323008' post='46840']
Yeah, Kyp is correct about Vista. Try to get to Windows 7 Pro or Ultimate when you can. Its a much better OS in many ways.

Something not touched on here is Internet Security software. Make sure you have an exception setup for Net-7 and the Client as well, then give it a whirl.

-Overt.
[/quote]

I made sure my exceptions where not blocking the program as well as my other firewalls/protective, etc.

I am happy to announce however that whatever in the update that snafu'ed my net7 from 1.7 to 1.9 has been resolved with whatever was fixed with the current version when I saw the note on the "secret mission" i deleted everything and reloaded it all. It confirmed I had .net, was admin, etc. etc. and have had no problems so far with it. (Knock on wood) :)

Thanks for the time and effort in responding to my posts and working the problem to make life easier for loading the game up as well.

bk
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...