Jump to content

Freezing at Almost Every Gate or Station


Recommended Posts

I've searched the forums for various possible solutions. I've seen a lot of threads about the issue or similar ones, but none of them really helped me thus far. It's possible I've missed *something* or other to try, though. So I apologize in advance for asking for help for something you all get bugged about a lot.

I've got everything running with admin privileges with compatibility mode and allowed by Windows Defender. Sometimes it lets me through gates or into stations normally and certain times seem to be better than others. The majority of the time, however, it just hangs and I need to either wait something like 17 minutes to get kicked to the login screen or ctrl+alt+del to close the game. Then when I do login, I'm on the other side of the gate and in seemingly random spots in the system, some of them far more dangerous than anywhere I want to be sitting around.

I would really appreciate any insight on stuff that I could have missed. I've really enjoyed the bit of the game I've gotten to play again and would like to keep playing, but the freezes make it really hard. Thank you for reading!

I've got some logs, of what I believe to be losing connection to the server when I gate. Here's from a time that I waited until I was kicked to the login screen.

18/07/22 04:09:36 ---> Server handoff
18/07/22 04:09:36 Received Master login confirm, new UDP port is 3565 Avatar_id = 0x400017c1
18/07/22 04:09:36 <server> Master Login received - UDP sector port: 3565
18/07/22 04:09:36 >> Commence Login check.
18/07/22 04:09:36 TCP connection on port 13470 closed gracefully
18/07/22 04:09:36 Sending Login packet - connection active
18/07/22 04:13:46 >> Intermediate Login check failed, re-issue sector login.
18/07/22 04:17:56 >> Intermediate Login check failed, re-issue sector login.
18/07/22 04:22:06 >> Intermediate Login check failed, re-issue sector login.
18/07/22 04:26:16 >> Intermediate Login check failed, re-issue sector login.
18/07/22 04:26:16 >> Login check: Login FAILED
18/07/22 04:26:16 login failed, go back to the login screen
18/07/22 04:26:16 Error receiving header on port 13470, error=10004 -- aborting
18/07/22 04:26:17 TCP connection on port 13471 closed gracefully
18/07/22 04:26:40 Received Master login confirm, new UDP port is 3565 Avatar_id = 0x400017c1
18/07/22 04:26:40 <server> Master Login received - UDP sector port: 3565
18/07/22 04:26:40 >> Commence Login check.

 

Link to comment
Share on other sites

since it isn't mentioned anywhere,

 

the most obvious one would be to check the server checkboxes in the net7 launcher

 

Packet Optimization

Prototype Reorder

Disable Mouse Lock

Delete TH6 Files

 

for most people, these all need to be ON.

Link to comment
Share on other sites

Here are a few more items to check:

  • Net-7 launcher must be version 2.2.0 (if it is not, or it crashes during the update, just keep running it until it is updated...this can take some time)
  • Net-7 launcher check the Local IP drop-down on the right side. If there is more than one IP listed select the bottom/last IP in the drop-down.
  • Make sure you have .NET Framework 3.5 (includes .NET 2.0 and 3.0) installed
  • Ensure you are running with an Administrator account and NOT a power user account.
  • Ensure 'run as administrator' is checked, on the 'Compatibility' tab for the client.exe, LaunchNet7.exe, and Net7proxy.exe
  • Windows defender/firewall: LaunchNet7, main (this is the client.exe), and net7proxy.exe MUST have their Public rule enabled to allow access.
Link to comment
Share on other sites

Thanks for the replies!

I've got the four checkboxes checked! I've played with them a little bit both ways for glorious science, but they're checked.

 

Launcher's the right version, the drop down thingy's only got one IP.

My Windows defender settings have the public rules set up.

I am an admin account.

And .NET 3.5 is installed.

 

But I've still got the problem.

Link to comment
Share on other sites

You may need to dig through your router/modem settings and ensure that net-7 and enb are both whitelisted by the firewall  and your antivirus,  some antivirus treat the game as unsafe,  make sure that you have it set to allow game through

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...