Jump to content
Morrundar

Anyone out there?

Recommended Posts

Just wondering if this is still alive.  Haven't been back in a long time, and the game doesn't run anymore.  Went to download to start over, but the game client doesn't download, only think I can get is the Net7 Unified Installer - which installs and allegedly updates, but as soon as it does, Net7Launcher then fails to run on Win10 ver 2004.  Was hoping it still worked and I just need to find the right tweak.

Share this post


Link to post
Share on other sites

Press Windows button

go to settings ... on the left

On windows setting page ... go to update and security

 

press the check for update and let it run.

 

once that is done ... 

go down that same page to  ... related links ... OS Build info 

 

Share this post


Link to post
Share on other sites

Thanks -however, my machine is already up to date (other than Win10, Version 20H2 update). I wouldn't think that is the culprit. :)  I did manage to download the game client, installed fresh, installed Net-7 launcher fresh, and it launches, updates the client once - then any launch after that (where it did create an installation error that previous posts say to Continue through), causes Windows 10 to say "This app can't run on your PC - to find a version for your PC, check with the software publisher".

 

Share this post


Link to post
Share on other sites

Yes, and I am an admin as well (but used the Run as administrator option). I will strip it all and try again, to be safe. 

Share this post


Link to post
Share on other sites

no other Mallware controlling software ? Since it's an old game sometime it run afoot of some security software 

Share this post


Link to post
Share on other sites

Rip/replace has helped, so that's good.  But now the launcher generates an error when I hit Play (after it fully updated), stating Incompatible version of Net7Proxy, latest version is 2.42. (then a Server Failed to respond to login attempt message)

Share this post


Link to post
Share on other sites

Hello

 

Recently a friend of mine had this issue when installing on a new computer. Not sure of the cause the but solution was to simply uninstall the Net7 package and then reinstall it again (allowing it to patch the client if you havent already) but also making sure its aiming at the correct executable for the client.

 

Below is how your launcher should look if default install directory is used, but also make sure your local ip is the one selected in the option menu on right side.

 

image.png.ff5b0b2384f70ba65d117847d7b32840.png

 

Regards

-FFT

Share this post


Link to post
Share on other sites

Appreciate the idea, but that takes me back to the original "Can't run on this PC" issue. I am noticing however, that LaunchNet7 is v1.9.9 no matter what I have updated.  Is it supposed to be updating itself to v2.2.0 or is there another download/update for it separately?

Share this post


Link to post
Share on other sites

eandb_demo.exe installed (run as admin used)

Net-7_Install.exe completed (run as admin used)

First update running as in Capture image. (shortcut set to run as admin)

Second launch after completion in CaptureB and CaptureC image.

 

Capture.PNG

CaptureB.PNG

CaptureC.PNG

Share this post


Link to post
Share on other sites

Go to net7 directory, right click on LaunchNet7.exe and net7proxy.exe and set to 'run as admin'.

Click LaunchNet7.exe right there, then under menu select 'Reset Version' (or something like that) which should recheck files.

Hopefully that gets it patched.

 

You could also try copying net7 and enb directories out of program files (ie to c:\Games) and uninstall both net7/enb packages.

Then run LaunchNet7 from new place and set client.exe to new place.

Share this post


Link to post
Share on other sites

LaunchNet7.exe from the C:\Program Files (x86)\Net-7\bin directory nd then doing Launcher > Reset Updates brings me Capture attached.  Second screenshot is where it errors, then the next is the result after the error, which then takes me to the original problem.  And now LaunchNet7 no longer works, until I remove all of it, and reinstall from scratch.

Capture.PNG

CaptureB.PNG

CaptureC.PNG

CaptureD.PNG

Share this post


Link to post
Share on other sites

Sorry to be such a pain with this, just can't figure out what I am doing wrong here.  Seems pretty simple and straightforward - it was before when I tried last (granted, it has probably been a couple years).

 

Share this post


Link to post
Share on other sites

go to %localappdata% (win+r then type and press ok) and delete LaunchNet7 directory (that has user config that gives the '5 not valid for index' error.

 

"This app can't run on this PC" might be because incompatible .net runtime. press win+r and type optionalfeatures and press ok

.net 3.5 is required I think, but you should have that already for v1.9 launcher).

 

It might also be net7proxy.exe. To figure out which exactly, run both of them from net7 directory and see which one gives that error.

Share this post


Link to post
Share on other sites

Deleted that folder, no change in result when launching directly from the Net-7 directory (LaunchNet7 or Net7proxy).

 

.Net 3.5 and 4.8 are both installed already.

 

Net7proxy.exe  causes them "Server failed to respond to login attempt"

LaunchNet7.exe launches, but clicking Play results in the error shown previously - Incompatible version of Net7Proxy. Latest version is 2.42, then the server error above.

 

Is there a newer version of the LaunchNet7 somewhere other than from it updating itself?  It's still v1.9.9 from anything I've downloaded. Maybe it should update itself, but I guess that is where I am getting stuck since it won't.

Share this post


Link to post
Share on other sites

Cannot download from that link. Any browser I use states Network Error and won't download it. Is there an alternate location or download area?

Share this post


Link to post
Share on other sites
1 minute ago, Morrundar said:

Cannot download from that link. Any browser I use states Network Error and won't download it. Is there an alternate location or download area?

 

check c:/windows/system32/drivers/etc/hosts file for any net-7.org entries. delete them from there. you do need to edit it with notepad which is launched as admin.

 

It is executable, so your antivirus might block the download aswell. if you cannot download from that url (http or https), then you out of luck.

Share this post


Link to post
Share on other sites

A/V isn't blocking it, it would create alerts if it did so.  The site is stating unreadable, from Chrome, Firefox and Edge.

 

My hosts file is empty of any entries that would supersede DNS.

Share this post


Link to post
Share on other sites
3 minutes ago, Morrundar said:

A/V isn't blocking it, it would create alerts if it did so.  The site is stating unreadable, from Chrome, Firefox and Edge.

 

yep, you out of luck.

Share this post


Link to post
Share on other sites

Guess so. Oh well. Maybe someone else will have an idea or a working site to download the update from.

Edited by Morrundar

Share this post


Link to post
Share on other sites
8 hours ago, Morrundar said:

Guess so. Oh well. Maybe someone else will have an idea or a working site to download the update from.

 

The url I gave you is the url launcher tries to patch itself. Some updates obviously are working for you, but you need to figure out why downloading LaunchNet7.exe fails in your computer.

 

Disabling antivirus/firewall temporarily for test, checking 'Network error' message if it gives reason for error.

 

Both of these links work on Win10/edge

https://patch.net-7.org/Net7/Files/bin/LaunchNet7.cfg

https://patch.net-7.org/Net7/Files/bin/LaunchNet7.exe

Share this post


Link to post
Share on other sites
9 hours ago, Morrundar said:

A/V isn't blocking it, it would create alerts if it did so.  The site is stating unreadable, from Chrome, Firefox and Edge.

 

My hosts file is empty of any entries that would supersede DNS.

 

Try https://www.opera.com , it's the one i Use when all the Google , Mozzila and Microsoft give me issues. 

 

Edited by WhiteOwl

Share this post


Link to post
Share on other sites

"NET Framework in Windows 10. ... NET 3.5 included with Windows 10"

 

Latest Net framework is at 4.8 , if memory serves me ( and this days it's a hit or miss ) when windows 10 came out a lot of legacy app had issues

due to that sucker that got updated almost weekly 

 

https://dotnet.microsoft.com/download/dotnet-framework/net48 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...