Jump to content

Help


Recommended Posts

you have to log in to the Net-7.org page and go to the menu selection for create a game account and create a game account,  then you should be able to log into the game.  DO NOT run the EA game launcher, it will not work,.  You must use the Net-7 launcher this will start the game and run it.  also if you want to play with the Terran Scout, Jenquai Seeker or the Progen Privateer, you must use the starship and character creator. the instructions for this are in the FAQ's and the forums..

Link to comment
Share on other sites

51 minutes ago, Woodstock said:

you have to log in to the Net-7.org page and go to the menu selection for create a game account and create a game account,  then you should be able to log into the game.  DO NOT run the EA game launcher, it will not work,.  You must use the Net-7 launcher this will start the game and run it.  also if you want to play with the Terran Scout, Jenquai Seeker or the Progen Privateer, you must use the starship and character creator. the instructions for this are in the FAQ's and the forums..

it is still not working it wants an EA login but im booting it with net 7

Link to comment
Share on other sites

I also am having issues, I wonder if it due to server transfer. Install is done, all steps on forum followed. Shows 2 game accounts linked to portal account, can log in here and the prtal just not the game. Net 7 client launches fine and shows server up, game launches without error just get told my login credentials are not correct.

Link to comment
Share on other sites

1 minute ago, Ferridius said:

I also am having issues, I wonder if it due to server transfer. Install is done, all steps on forum followed. Shows 2 game accounts linked to portal account, can log in here and the prtal just not the game. Net 7 client launches fine and shows server up, game launches without error just get told my login credentials are not correct.

oh so its not just me

Link to comment
Share on other sites

2 hours ago, Ferridius said:

I wonder if it due to server transfer.

Yes it is.

The forum is on the new server already, which is connected to the new game server - but the latter hasnt been moved yet.
I transfered your game account from the new server to the old server so you should be able to login now.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...