Jump to content

Chronic, Intermittant Problem With Net-7 Proxy


Noconos

Recommended Posts

Hi. First off, thanks for resurrecting this game!

Next, I have an issue with the net-7 installer.

I have 2 machines, identical except for video cards, 64 bit Vista, running as admin, UAC disabled, set to xp compatability mode, ebconfig run after install.

when I install the net-7 installer, I get the following:

Unhandled exception has occured in your application. If you click Continue, the application will ignore thiserror and attempt to continue. If you click Quit, the application will terminate immediately.
InvalidArgument = Value of '5' is not valid for 'index'.
Parameter name: index

details:
************** Exception Text **************
System.ArgumentOutOfRangeException: InvalidArgument=Value of '5' is not valid for 'index'.
Parameter name: index
at System.Windows.Forms.ListViewItem.ListViewSubItemCollection.get_Item(Int32 index)
at LaunchNet7.FormUpdateReport.DoDisplayUpdateReport()
at System.Windows.Forms.Form.OnLoad(EventArgs e)
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.Control.CreateControl()
at System.Windows.Forms.Control.WmShowWindow(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4223 (VistaSP2GDR.050727-4200)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll
----------------------------------------
LaunchNet7
Assembly Version: 1.9.9.11
Win32 Version: 1.9.9.11
CodeBase: file:///C:/Program%20Files%20(x86)/Net-7/bin/LaunchNet7.exe
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4228 (VistaSP2GDR.050727-4200)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4223 (VistaSP2GDR.050727-4200)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4230 (VistaSP2GDR.050727-4200)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Configuration
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
Accessibility
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Accessibility/2.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.






Clicking Continue will allow the install to proceed, and sometimes the game will work fine for a day or 2, sometimes not at all (I have reinstalled 6 times now). When it works, I get a message EVERY time that I log off the game that Net-7 Proxy has stopped working. Sooner or later, when I attempt to login, the client just starts shutting down after I have input username/password and hit accept. Rather than getting the handprint animation and character selection screen, the window just closes. Once this happens, I have to uninstall/reinstall, sometimes multiple times to get it working again.

Following some advice I have found in other posts, I have tried deleting the TH6 files from the EandB/data/mixfiles, I have tried deleting the files in the user/appdata, i have tried forcing an update, I have opened TCP443 and UDP 5500-6000, all to no avail.

Any help would be appreciated. TIA
Link to comment
Share on other sites

  • 4 weeks later...
I am having same problem. net7proxy crashes ."Rather than getting the handprint animation and character selection screen, the window just closes" then i get a popup on desktop that says net7proxy.exe has stoped working.
Link to comment
Share on other sites

  • 1 month later...
Yea - my vista machine does the same also. Closes down after login. Pop up saying net7 has stopped working. Yes it is wireless, but so is this XP machine and works fine.

Okay - so Devs don't like Vista, but it's what I got. Any chance of a fix?
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...