Jump to content

Everyone's favorite INV-300 error


Recommended Posts

Hey there,

I've run through the gauntlet of searching here and looking at the faqs. I can log in normally if I use the local cert option but other then that I get the EA.com is unavailable. I updated the certificate file but still no joy. Any words of wisdom out there?

Link to comment
Share on other sites

Hey there,

I've run through the gauntlet of searching here and looking at the faqs. I can log in normally if I use the local cert option but other then that I get the EA.com is unavailable. I updated the certificate file but still no joy. Any words of wisdom out there?

Hi all,

I am having the same problem but, in addition, the game crashes if I switch to the local certificate in the net7 proxy.

Link to comment
Share on other sites

If this helps, I am getting an "SSL write failed" in the Net7 proxy prior to trying to login with the local certificate selected after performing the download and install procedure for the certificate. This results in the game crashing when I try to log in.

Using it without the local certificate selcted does not seem to throw errors until I try to log in whereupon I get the INV-300 error.

Any help would be greatly appreciated.

Link to comment
Share on other sites

+1 Been playing fine w/o local cert, logged in earlier today (around noon) no problem. Now all I get is INV-300.

was able to login using Local certificate + Packet Optimization.

make sure the Net-7 Launcher and Client are running with admin rights. XP SP2 compat mode might help i guess.

That's fine, but you can't use local cert when dual boxing.

-JoeTD

Edited by JoeTheDestroyer
Link to comment
Share on other sites

OK, I have tried updating certificate, running with and without compatibility mode (currently running Win7), running with and without packet opt, and with and without local cert, with and without administrator rights. Using local cert always crashes after trying to log in to the game. Using local cert unchecked always gives INV-300 error.

Now what? Try a complete reinstall of proxy?

Edited by Buranka
Link to comment
Share on other sites

try again now. It looks like the script kiddies out at play again. I'll look at the logs and just have the login server auto-reset itself when it gets locked up like that.

Bah, that's really crappy.

Looks like the Local-Cert workaround is failing for me now:

15/02/11 20:03:50 Attempting to connect to IP address: 87.106.15.67

15/02/11 20:03:50 Sending login.

15/02/11 20:03:51 login OK

15/02/11 20:03:51 UDP packet optimisation selected (reduces server load).

15/02/11 20:03:51 Connecting to Authentication Server on 87.106.15.67:443

SSL_CTX_use_PrivateKey_file failed

And regular cert is still giving me that lovely error. I'm patient though.

Edited by Eldarath
Link to comment
Share on other sites

Looks like the Local-Cert workaround is failing for me now:

...

SSL_CTX_use_PrivateKey_file failed

That's caused by replacing the old "local.net-7.org.cer" with the new one in the net7 bin folder. If you restore the old, expired one, then local-cert will work again.

It's actually not needed in the bin folder anyways, the only thing you really need to do with the new cert file is import it into the Windows certificate store. (i.e. you can leave the old cert in the bin folder with no ill effects, I do. Just don't ever use the net-7 install certificate option, or things will get messed up and you have to use the windows certificate manager to fix it).

-Joe

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...