Jump to content

Galaxy map freeze ("Receiving Initial login data")

Recommended Posts

Gooodafternoon everyone,


A few days i'm trying to get myself reconnected again with E&B. With no succes 😞

Woodstock tried to help me to fix the problem, but no luck so far. (appreciated his help)

He told me to post a topic on the forum!


The problem is: that i can login to my characters but i can create new ones. After i click a character my screen stays in the galaxy map screen.

In my system tray i see a square that says "Receiving Initial login data"

I tried a lot of things, but i haven't had any luck so far.


I shall copy paste a few things i already did try:



I updated Net-7 to version 2.2.0. Also i marked all 4 options you descibed in your answer.
Inside the game i can just login with my account: (bugsie2)
I see all my characters after that. Even the ones i transfered from an other account. Wanted to check if account linking worked on the net-7 portal.

I changed 3 executables to compatibilty Windows xp Service pack 3. And i execute them as

- Net-7 "C:\Program Files (x86)\Net-7\bin\LaunchNet7.exe"
- C:\Program Files (x86)\EA GAMES\Earth & Beyond\release\client.exe"
- C:\Program Files (x86)\EA GAMES\Earth & Beyond\EBCONFIG\E&BConfig.exe"

Hope you have any other suggestion. I use Windows 10 Pro btw.

Thanks in advance




Update i changed a few more executables:

- C:\Program Files (x86)\EA GAMES\Earth & Beyond\EBCONFIG\VIDTEST
- C:\Program Files (x86)\Net-7\bin\Netproxy





I created a new account (Eclip2). I had the same problem. I created a new character (Progen Warrior)
After it was created, loading screen appears and it freezes.



I tried several things so far:

- Turned off Windows Defender.
- I don't have any other Anti Virus program. I only use the software that is provided by Windows 10. (also no clue where those settings should be)

- I thought it could be my Internet Connection at home. Therefore i tried to play the game, by setting my Iphone as my main internet connection. Unfortunately no succes.

- I also changed the complete map of Earth and beyond and Net-7 to complete access.




Anyone got time to get this thing going! Much appreciated. 

Thank you already for your time.





Link to comment
Share on other sites

1) Make sure you have .NET Framework 3.5 (includes .NET 2.0 and 3.0) installed

2) Ensure you are running with an Administrator account and NOT a power user account.

3) Try copying Net-7 and ENB to a drive other than the C drive and running it from there. Windows loves to lock down the C drive.

4) Ensure 'run as administrator' is checked, on the 'Compatibility' tab for the client.exe, LaunchNet7.exe, and Net7proxy.exe

5) Don't disable windows defender/firewall. LaunchNet7, main (this is the client.exe), and net7proxy.exe MUST have their Public rule enabled to allow access.

6) Your modem and /or router could both be blocking access (some modems have routers built into them and will block access if this option is NOT disabled). You would need to login to each device to ensure UDP and TCP connections are not being blocked.

Edited by jrichards
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...