Jump to content
caine6621

Incompatible version of Net-7 Proxy

Recommended Posts

There was a problem during the patch today and now I can't launch.

 

I get the incompatible version of Net-7 Proxy, current version is 2.41

 

When giving me advice please remember I am only semi computer savvy

Share this post


Link to post
Share on other sites

try resetting the updates on the net-7 launcher

Share this post


Link to post
Share on other sites

I found a sort of awkward solution, this is after trying to reset the updates and reinstalling. I launched net7 and didn't press play, uninstalled net7 while the launch window is still open, then pressed check for updates and it came with the cannot detect version window and update, then i reinstalled net7, i got an error during reinstallation that it couldn't read or write to a specific file, clicked ignore and it went ahead. then went back to the launch window and continued with the update. after that everything went fine, did this on 2 computers a xp and win7 one. like i said its an awkward fix but worked for me.

Share this post


Link to post
Share on other sites

Unfortunately am getting no where. Wants 2.44 Net7Proxy and it fails to download it no mater what I do.

Share this post


Link to post
Share on other sites

Launcher needs to run in admin mode, you read that in the guide, right?

Share this post


Link to post
Share on other sites

Launch Admin mode and tell it to reset the updates, this should bring you from 'default' to current regardless of settings and should overwrite anything in the current release as we do. I'm not sure which Net7Proxy we're on without looking into it, but it may not be that version and we don't really retain older copies due to generally no need. When we update that, we want you to update as well and release it to you. Without a valid version, you cannot connect to the emulator.

Share this post


Link to post
Share on other sites
8 hours ago, Kyp said:

I'm not sure which Net7Proxy we're on without looking into it

 

Current Version is 2.44, which is also the one sitting on the update server.

Share this post


Link to post
Share on other sites
On 9/9/2018 at 3:03 AM, Zackman said:

 

Current Version is 2.44, which is also the one sitting on the update server.

i can not get it o work ether

Share this post


Link to post
Share on other sites

Recheck the version, i guess you didn't run the updater/launcher in admin mode, so the executable (proxy) wasn't updated.

Share this post


Link to post
Share on other sites

Anyone still have the net-7 single player version. The one that do not use mysql. 1.7 I think. Was a limited version but can use beta/admin commands. I did with tada-o version (sourceforge) but is a pain old mysql server and debug mode. The one that was xml file was funny. Thank you.

Edited by Antflyer

Share this post


Link to post
Share on other sites
On 1/5/2019 at 9:15 AM, Antflyer said:

Anyone still have the net-7 single player version. The one that do not use mysql. 1.7 I think. Was a limited version but can use beta/admin commands. I did with tada-o version (sourceforge) but is a pain old mysql server and debug mode. The one that was xml file was funny. Thank you.

 

No, we didn't retain this after we got to a stable multiplayer mode.

Share this post


Link to post
Share on other sites

I get "server failed to respond to login attempt" when I try and start via net-7 proxy. I reset updates in admin mode and did all the steps others have done and still have the same issue.

Share this post


Link to post
Share on other sites

I did a completely fresh install on another PC and it's giving me the same proxy error...

Share this post


Link to post
Share on other sites
10 hours ago, Beerrun said:

I get "server failed to respond to login attempt" when I try and start via net-7 proxy. I reset updates in admin mode and did all the steps others have done and still have the same issue.

 

Wrong internal IP selected on launcher or incoming UDP connection is blocked by firewall / router.

Share this post


Link to post
Share on other sites

to everyone who is having install issues:  -- hang in there.  Earth and Beyond does work.

 

and, PLEASE -- when you post your problem, tell the DEVs what operating system you are running and which service pack.  If you're trying to use a Windows emulator [on either an iMac or Linux box], they need those details as well.

 

Yes, Earth and Beyond apparently still runs on Win XP [SP 3].  It runs on Win 7 64 bit [I'm less sure about 32 bit -- haven't had a 32 bit computer in over a decade now].  It runs on Win 8 and Win 10.  Yes, you have to run the install under admin privileges [MicroSoft won't allow programs from outside sources to automatically select "run as admin" -- it's a fundamental safety measure].  And YES, after the program is installed, you then have to manually set the LaunchNet7.exe file to "run as admin" as well as run under the proper Windows compatibility mode {Win XP, SP 3 -- I admit that I'm unsure of this for Win 10 users since I'm refusing to use that operating system myself}.

 

And yes, it is quite possible that your anti-virus or anti-malware program, including the firewall in your router or computer, is stopping EnB from communicating with the server.  This can be fixed by creating an exception for the LaunchNet7.exe file in the preventing program.

 

 

We're looking forward to seeing you ingame ....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×