Jump to content
Ztyx

Rolands Henchmen group aggro? (TT L30 bonus mission)

Recommended Posts

I seem to recall from Live and when I was playing before the reset, that when doing the TT level 30 bonus mission, you could fight one of Roland Holmes Henchmen in Slayton and the others would leave you alone (I did this solo before with no problem). Now, when doing this mission, I get 3-4 Henchmen group aggroing me and with a whole storm of inbound missiles you are calling for a tow before you know what hit you.

 

Is this something that was changed recently? Do I really need to get a big group with me (and try to avoid the missile storm) just to kill a CL15 Henchman to complete the mission, when before I could easily solo it? Or am I just doing something weird? :(

Share this post


Link to post
Share on other sites

Hmm, you should only agro the mob you attack. 

 

If you are consistently getting a group of them to agro you should submit a bug report.

Share this post


Link to post
Share on other sites

This actually happened to me as well when I did that mission, but I thought that was just how it functioned. I died on the first attempt to kill one of the henchman because they all aggro'd. I towed, and came back a second time at a distance from the nav point so I could pick one of them off from a distance and I was successful in doing that. I guess it's good to know that I shouldn't have gone through all that trouble though.

Share this post


Link to post
Share on other sites

It happened to me also, so I changed tactics, picked on a mob away from the others and kited him. Took tons of ammo but finally got him.

Share this post


Link to post
Share on other sites

Due to nature of mission (and mission text) it is a volunteerly one-on-one fight, or should be...

 

Holmes offers you to take one of his henchman down if you can. Basically henchmen should not call-for-help from other henchmen... 

 

However currently it is not in that state even though they are yellow.

Edited by SiSL

Share this post


Link to post
Share on other sites

Thanks for confirming this is not just me. I have posted a bug report about this, guess I'll have to sneak in and kite a stray for now. :mellow:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...