Jump to content
crowey

New server :cant login any toons

Recommended Posts

Yazuly    2
On 12/20/2016 at 3:34 AM, karu said:

Make sure you have correct internal IP on launcher selected

Yes I do have the correct IP on the server launch pad.

I'll restate the problem again. I can get to the game fine if I don't run my VPN.

IF I RUN MY VPN THEN, AND ONLY THEN, I GET Server failed to respond to Login attempt.

Do you understand the issue now? Sorry to be so curt but I think sometimes you read the posts too quickly and don't see the real problem that is reported. No VPN = success, with VPN = failure. I am using UDP on the VPN.

Do you need any more information on how I have the VPN set up?

EDIT: what do I need to check in the hosts file?

EDIT2: I found this in the hosts file located at C:\Windows\System32\drivers\etc

# Copyright (c) 1993-2009 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

# localhost name resolution is handled within DNS itself.
#    127.0.0.1       localhost
#    ::1             localhost

 

Edited by Yazuly

Share this post


Link to post
Share on other sites
Kyp [LDEV]    239
21 minutes ago, Yazuly said:

Yes I do have the correct IP on the server launch pad.

I'll restate the problem again. I can get to the game fine if I don't run my VPN.

IF I RUN MY VPN THEN, AND ONLY THEN, I GET Server failed to respond to Login attempt.

Do you understand the issue now? Sorry to be so curt but I think sometimes you read the posts too quickly and don't see the real problem that is reported. No VPN = success, with VPN = failure. I am using UDP on the VPN.

Do you need any more information on how I have the VPN set up?

EDIT: what do I need to check in the hosts file?

EDIT2: I found this in the hosts file located at C:\Windows\System32\drivers\etc

# Copyright (c) 1993-2009 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

# localhost name resolution is handled within DNS itself.
#    127.0.0.1       localhost
#    ::1             localhost

 

Nope, he's just going through common fixes to ensure that you've checked them. Sometimes it will be directed at the wrong IP after installation and this causes a network routing failure.

This will all depend on your VPN, do you have split tunneling configured? If not you have to make sure you have routes to the internet and thus our systems because you would be going through your VPN concentrator/firewall device instead of using your local DNS/gateway for internet related activity. Honestly it sounds like it's not configured as a split tunnel and you don't have routes easily accessible to the internet.

Try connecting to VPN then doing a traceroute to sunrise.net-7.org and patch.net-7.org and post the results. I'm suspecting it is simply timing out trying to reach out. If so that would point at a configuration issue on the VPN. I say all this because I recently experienced the same kind of issue with some of our services during the server move and realized that I'd been routing through our firewall device for internet traffic and that's where it was going south. After I configured and enabled it as a split tunnel it began working normally.

Share this post


Link to post
Share on other sites
Kyp [LDEV]    239

Also, the posted hosts file is entirely default. Nothing to change there.

Share this post


Link to post
Share on other sites
Zackman [LDEV]    124
16 hours ago, Yazuly said:

IF I RUN MY VPN THEN, AND ONLY THEN, I GET Server failed to respond to Login attempt.

Gaming (UDP) over a VPN line is not working without some special configuration on the VPN server.

Hints:
Gateway Route pushed?
Internal IP4 forwarding enabled?
Access behind the virtual VPN IP allowed (so called "inter client connect")

 

Share this post


Link to post
Share on other sites
karu [WDL]    23
On 12/26/2016 at 11:11 PM, Yazuly said:

Yes I do have the correct IP on the server launch pad.

Screenshot available IPs on the dropdown please including the launcher window fully visible

Share this post


Link to post
Share on other sites
Yazuly    2

Here is screen shot with VPN disconnected (this is my main PC not to be confused with the PC I will discuss later). With VPN disconnect I can login no problem. I'm assuming this is the correct IP on launcher screen as it is the only one available.Launcher Sscreen VPN disconnected and this works.png

I have to admit I'm a little lost with Kyp's explanation on the VPN (I'll have to google some things to get more educated). Obviously since I can login in without the VPN running it must be the VPN having the issue. I tried different cites and different 'public' IP addresses and no luck there. Maybe a firewall issue? - I ask that because of issue I'll discuss on another PC at end.

The other thought I have, while writing this, is maybe I need to somehow add the 'public' IP (on the screen shot that would be 104.223.94.218)?

 

PART2:

Just to confuse the situation further I have another PC I use as a test PC. It is pretty plain vanilla Win10, no VPN, not much in other software. I got the same error message about login server failure. But on that PC's launcher screen I have a choice of 3 different IPs (all different from the VPN PC's launcher screen). First two did not work (192.168.40.1 and 192.168.65.1). The local IP  that did work is 192.168.1.101 which if I remember correctly is probably that PC on the network? When I selected that IP from the drop down I got a message saying Windows firewall was blocking. Once I allowed it through the firewall it worked. I did not include a SS of that PC's launcher because I didn't want to add more confusion. I will attach that if requested.

Worst case I can also use the test PC to play if I don't want to drop the VPN on the main PC. So there are workarounds on my end. But I really like to understand what is not configured correctly using the VPN. I can connect to others games with it.

Thanks for the continued help and patience on this.

Edited by Yazuly
Corrected typos and grammer

Share this post


Link to post
Share on other sites
Yazuly    2

Problem Solved. Kyp was right about the local IP not being correct. Attached is the screen shot that works. There was another IP address available on the drop down when the VPN is connected. That matched the 'local IP' displayed by the VPN when the VPN was connected.

Launcer Screen VPN Works.png

Chalk it up to a very embarrassing SUE (Stupid User Error).

Share this post


Link to post
Share on other sites
Kyp [LDEV]    239

VPNs are complex beasts, so SUE doesn't always apply.

Share this post


Link to post
Share on other sites
Janwarrior    0
On ‎14‎/‎11‎-‎2016 at 4:56 PM, Zackman said:

There is one thing more tho:

Another bit in the chain which was already causing trouble for some in the past and getting more "weight" currently.
While this temp fix on the server is working for many people, some still have problems - and this is based on how the local network is setup.

People having problems need to make sure they do have a full NAT setup with correct port forwarding.
If the server is handing over a player, the server and the local player-proxy are negotiating a new port (sector port, UDP).

If this communication is going wrong, because the local firewall doesnt know where to route these packets, you are lost.

If you only have one(!) computer in your house playing the game, you could add firewall NAT rules like this:
Source: 38.130.197.232
Source Port: any
Redirect IP: <the IP of your local network computer>, eg. 192.168.0.50)
Destination Port: "as is"   or   "any"

Some firewalls call this "1:1 mapping", others call it "Nat Punch" or "Nat hole punching" etc. - so consult your Router/Firewall Manual.

The goal is to tell the firewall:
"No matter what packet comes in and on what port - if it comes from the game server (38.130.197.232) route it to my local computer on the same port."

This is based on the fact, that UDP packets are "fire and forget", so if the server sends packets on a new (hand over) UDP port, the firewall doesnt know where to route it to and it gets dropped - your communication to the server is dead in this very second.

People not experiencing this problem are most likely having a correct NAT Setup.

And finally, just for the record:
This is nothing special at Net-7. Basically every gamer is suffering from this issue, if the game is not running TCP protocol (WoW eg. is TCP).
 

I have one problem here...

Today I got my Internet modem replaced.
The trouble is that the NAT rule is working the *opposite way* - that is - the rule woks only if it is *unmatched*...
Another creepy/tricky - thing is that the subnet mask *has* to be correct!!

Now assuming that my local IP Address is 192.168.254.103, how shall I then set up the parameters?!

Thank you all for any kind of good (!) ideas... :)

BTW: I don't have this trouble while running through VPN...
Clearly it is a configuration problem at Globe Telecom, Philippines! >:(

Edited by Proconsul Janwarrior
Update of info...

Share this post


Link to post
Share on other sites
Zackman [LDEV]    124

192.168.254.103

Would be

192.168.254.0/24

or 

192.168.254.0/255.255.255.0

Depends in the Format the Router is expecting.

 

 

 

 

Share this post


Link to post
Share on other sites
Janwarrior    0
4 hours ago, Zackman said:

192.168.254.103

Would be

192.168.254.0/24

or 

192.168.254.0/255.255.255.0

Depends in the Format the Router is expecting.

 

 

 

 

 

The rule has to be setup as *unmatched*...

 

Edit:

Source IP Address: .... (0.0.0.0 means Don't care)
Subnet Mask: ...
Post Number: 0 (0 means Don't care)

Destination IP Address: ... (0.0.0.0 means Don't care)
Subnet Mask: ...
Port number: 0 (0 means Don't care)

Protocol: TCP/UDP/ICMP (Dropbox)
Rule Unmatched: Forward/Next (Dropbox)

x2.jpg

Edited by Proconsul Janwarrior
Screenshot

Share this post


Link to post
Share on other sites
Zackman [LDEV]    124

Protocol UDP

Source 38.130.197.232

Subnet 255.255.255.255

SourcePort: 3500 - 4000

Destination: IP oft your game pc

Subnet 255.255.255.255

 

Share this post


Link to post
Share on other sites
Janwarrior    0
2 hours ago, Zackman said:

Protocol UDP

Source 38.130.197.232

Subnet 255.255.255.255

SourcePort: 3500 - 4000

Destination: IP oft your game pc

Subnet 255.255.255.255

 

IP / MAC Filter Set Index 123456789101112   Interface PVC0   Direction Both
 
     
# Active Src Address/Mask Dest IP/Mask Src Port Dest Port Protocol Unmatched
1 Yes 38.130.197.232/
255.255.255.255
192.168.254.103/
255.255.255.255
0 0 UDP Forward
2 - - - - - - -
3 - - - - - - -
4 - - - - - - -
5 - - - - - - -
6 - - - - - - -
 
         
   

I can only put in ONE port, not a range...

While doing it this way, I get server status OFFLINE!!

I guess it has something to do with the Unmatched" conditions to do???

Edited by Proconsul Janwarrior

Share this post


Link to post
Share on other sites
Zackman [LDEV]    124

Oh dang, only one Port?

Try to enter like this:
3500-4000   or    3500:4000

If both are not working, i would consider a new router.
TP Link is great - it's network stuff for a lower budget (WiFI Router, USB Dongles, Range extender etc.)

If it comes to detailed firewall rules, there are better products.
Since you need a router with an ADSL2+ modem built in, another choice would be Fritzbox or the Zyxel Speedlink 5501 or even an older (used) Linksys WRT54g with a DDRT Firmware.

Share this post


Link to post
Share on other sites
Zackman [LDEV]    124

PS.:

Unmatched condition only means:
"If this rule is not applying to the current incoming packet, go to the next rule" - which is the "Forward" choice for "unmatched rule".

That would be the default selection.

 

Share this post


Link to post
Share on other sites
Janwarrior    0
1 hour ago, Zackman said:

PS.:

Unmatched condition only means:
"If this rule is not applying to the current incoming packet, go to the next rule" - which is the "Forward" choice for "unmatched rule".

That would be the default selection.

 

If I put in the stuff, with port don't care (0), then Net-7 appears as OFFLINE...

The router is part of the replaced Wi-Fi modem/router from GLOBE TELECOM, Philippines.

Share this post


Link to post
Share on other sites
Janwarrior    0

How can I BTW get rid of uploaded content?

Share this post


Link to post
Share on other sites
Zackman [LDEV]    124
10 minutes ago, Proconsul Janwarrior said:

How can I BTW get rid of uploaded content?

You cant. It stored on the Forum server.

 

10 minutes ago, Proconsul Janwarrior said:

If I put in the stuff, with port don't care (0), then Net-7 appears as OFFLINE...

I can only give limited advise without having the router in front of me. I also dont use/own this router myself so my tipps are of theoretical nature, you need to find out the correct configuration. It could be, the rules are correct but the router has a misconfiguration at a different setting point.

Generally:
Two way to enable correct NAT:
"Port forwarding (UDP packet from <xxx> on port <xxxx-yyyy> are forwarded to internal machine <xxxx> on ports <xxxx-yyyy>

or (easier/better)
"Full NAT and masquerading" <- needs more network knowledge but will lead to a flawless configured firewall functionality.

 

PS:
You might want to cosider calling a friend who really KNOWS router configuration and might help you here.

Share this post


Link to post
Share on other sites
Janwarrior    0
15 minutes ago, Zackman said:

You cant. It stored on the Forum server.

 

I can only give limited advise without having the router in front of me. I also dont use/own this router myself so my tipps are of theoretical nature, you need to find out the correct configuration. It could be, the rules are correct but the router has a misconfiguration at a different setting point.

Generally:
Two way to enable correct NAT:
"Port forwarding (UDP packet from <xxx> on port <xxxx-yyyy> are forwarded to internal machine <xxxx> on ports <xxxx-yyyy>

or (easier/better)
"Full NAT and masquerading" <- needs more network knowledge but will lead to a flawless configured firewall functionality.

 

PS:
You might want to cosider calling a friend who really KNOWS router configuration and might help you here.

I started to work with Personal Computers back in 1985...

I will try to contact GLOBE TELECOM - Tomorrow.

Share this post


Link to post
Share on other sites
Zackman [LDEV]    124
2 minutes ago, Proconsul Janwarrior said:

I started to work with Personal Computers back in 1985...

I dont doubt and my previous posting wasn't meant to offend.
On the other hand, i know a lot of people "working with computers" for a long time - that doesn't necessarily means they can handle network/firewall configuration.

It was a general suggestion to call some1 in - without any personal "skill judging".

 

  • Upvote 1

Share this post


Link to post
Share on other sites
Janwarrior    0
On ‎08‎/‎01‎-‎2017 at 4:50 PM, Zackman said:

You cant. It stored on the Forum server.

 

I can only give limited advise without having the router in front of me. I also dont use/own this router myself so my tipps are of theoretical nature, you need to find out the correct configuration. It could be, the rules are correct but the router has a misconfiguration at a different setting point.

Generally:
Two way to enable correct NAT:
"Port forwarding (UDP packet from <xxx> on port <xxxx-yyyy> are forwarded to internal machine <xxxx> on ports <xxxx-yyyy>

or (easier/better)
"Full NAT and masquerading" <- needs more network knowledge but will lead to a flawless configured firewall functionality.

 

PS:
You might want to cosider calling a friend who really KNOWS router configuration and might help you here.

I started to work with Personal Computers back in 1985...

Visit from GLOBE Telecom Today, impossible to upgrade firmware.

I will try to look for another solution, late next week.

Share this post


Link to post
Share on other sites
Janwarrior    0
On ‎08‎/‎01‎-‎2017 at 5:12 PM, Zackman said:

I dont doubt and my previous posting wasn't meant to offend.
On the other hand, i know a lot of people "working with computers" for a long time - that doesn't necessarily means they can handle network/firewall configuration.

It was a general suggestion to call some1 in - without any personal "skill judging".

 

I have found a - rather - strange - solution:

Some time ago I got access, to a Windows 2012 R2 VPS...

Now I am running VPN that way (!), and that seems to work - very well!!! :)

Share this post


Link to post
Share on other sites
Zackman [LDEV]    124

...because the VPN Machine is acting as a "proxy" now - and obv. the network configuration is setup correct as "full nat".

Basically this is indicating that your local network configuration is not full nat'ted.

  • Upvote 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×