Jump to content
Amoor

Engine Thrust/trails Animations And Suggestions.

Recommended Posts

Hi,

 

I have just started playing on the emulator 2 months ago,  been really great and I am thankful that I am able to play EnB again. You guys did a great job bringing this game back to life.

 

My PW reached level 150 recently, and since level 100 I have always felt that there is something wrong or missing with the how the ship used to fly and engine thrust/trails animation, so yesterday I decided to look for my old EnB screenshots and was lucky enough to find them on an old hard drive.

 

After watching several screenshots I can now confirm that I was right, I don't know if this is working as intended or not but I decided to share with you guys my screenshots anyway, so you can see what I am talking about:

 

[attachment=3187:ScreenShot204.jpg]

This is my PW back on live, notice the engine trails behind the ship, and the 4 flares. After each hull upgrade everything about the ship start to look better and bigger, including engine animations. Currently we are flying lvl 150 ships with lvl 1 engine animations. Even though the ship's hull and wings gets upgraded to the appropriate design with each hull upgrade, the engine remains the same which makes the look incomplete to me.

 

[attachment=3188:ScreenShot125.jpg]

Another screenshot thought I'd also share showing engine trails and damage I am receiving which is another thing I have also noticed. If you look at shield bar, you will notice that it used to report if the the damage I received was critical or not, and if it was, it used to do a screen shake with a certain high pitched warning noise. Currently we have none of that.

 

[attachment=3189:ScreenShot13.jpg]

This is my TE, he also used to look like this with max hull upgrade.

 

[attachment=3190:ScreenShot239.jpg]

Warping animation.

 

Same situation with my JD and JE, they used to look different on live, and I have more screenshots if you guys are interested to see it.

 

If this is known issue and was intentional to be like that,  I apologize I just started seriously playing on the emulator and missed a lot since it started. And I thought to add what I noticed to make the game better for all of us.

 

 

Share this post


Link to post
Share on other sites

For thrust trails = each engine will give you a different con-trail.

 

Hull = there are three hulls to choose from. and three wing settings that you can have.

 

Shield Bar = I see the damage and the critical hits on all my shield bars.

 

This could be why it looks different, you might not have the same configuration.

 

Just a Thought.

Share this post


Link to post
Share on other sites

Thanks Syberfly,

 

But if I remember correctly it didnt matter which hull/wing style you choose, or what type of engine you have installed, you'd always get the same trail and effects. I believe it is the same on the emulator, it is just the missing animation I am talking about that is related to you Hull level nothing else. And for the record my current PW have the same hull and wings as on live.

 

In the picture where i am shooting at the master. you can clearly see that Progen warriors used to leave 4 engine trails behind them with flares showing at each. I never seen a PW leaving trails like this behind them on the Emulator.

 

I always see the damage on my shield bar, I was just pointing out that It never indicates critical hits and I never hear the high pitched warning noise that used to happen with each one.

 

Share this post


Link to post
Share on other sites

This is what PWs look like now.

 

 

4sod4l.jpg

 

 

And this is a better picture showing detailed damage reporting am receiving.

 

 

2utqluc.jpg

Edited by Amoor

Share this post


Link to post
Share on other sites

i agree with amoor here my pw didnt feel as mac truck like while driving and this was the issue can we get a dev comment on this? is if fixable so on so forth :D

 

edit

 

if u watch your ship (pw) u can clearly tell only two of the 4 engine thrust exhausts are working

Edited by Echar

Share this post


Link to post
Share on other sites

I asked about this quite a while ago, as far as I can tell the engine component of the ship isn't getting upgraded properly with the rest of the ship. The jenqui hulls get the first 1-2 upgrades but none of the races get the final one which made them look like the screen shots in the 1st post.

Share this post


Link to post
Share on other sites
It may not 'feel' the same, but the thrust values were matched up to the live game for all existing classes. It's just a matter of perception where speed is concerned. As for the effects, not as sure. Memory doesn't stretch back that far clearly.
Also, when upgrading and your ship is changed, log out and back in to ensure that your ship is redrawn according to current spec. We've had some problems with that in the past but usually logging out and back in sorted them out.

Share this post


Link to post
Share on other sites

Thanks Kyp, the effects are clearly not the same for all classes as shown in my screenshots from the 1st and 4th post. Notice the speed of my PW in the screenshot in my 1st post (Live), and speed in 1st screenshot on the 4th post (Emulator). Both are same hull configuration and the thrust speed very close.

 

The effects are not the same, to me it looks like the effects from the lvl 75 or lvl 100 PW hull upgrade.

 

I understand the values are matched to live since the ship's hull gets upgraded after every hull lvl, but clearly there is something missing about the thurst animation for all classes especially progen warriors since at max hull lvl they used to get 4 thrust trails.

 

Thanks

 

Edit : Screenshot added

 

This is my PW rear engine exhaust up close, notice the 2 engine port per side and only one of them firing. PWs get this 2nd exhaust per side ( total 4 exhausts) after lvl 135 hull upgrade. Right now only 2 is firing and the flare effects are not enabled.

 

359msnc.jpg

Edited by Amoor

Share this post


Link to post
Share on other sites
We will put it on the list to look at.

Share this post


Link to post
Share on other sites

This video has some clips of what the jenqui 150 engines/trails should look like and here's a video showing what the progen 150 engine/trails look like. These are really old vids from before sunset. 

Share this post


Link to post
Share on other sites

Thanks Paul for the videos , yeah that is exactly what I was looking for when i received my lvl 135 hull upgrade on PW. I hope it gets fixed.

Share this post


Link to post
Share on other sites

Just as a side note as nothing seems to have happened for ~6 months... 

 

We are not talking about the equipable engines...

 

We are talking about the engine component that makes up the 3D model of the ships (hull/wing/engine).

Share this post


Link to post
Share on other sites

Awww yeah, dat lens-flare X on the JE. Memories. I miss that alot. It was so nice and added really -alot- to the visual badass-factor of max-hull ships.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...